World-Designs-Forum  

Go Back   World-Designs-Forum > Members List
Register FAQ Members List Calendar Gallery Today's Posts Search Today's Posts Mark Forums Read

John Caswell John Caswell is offline

Super Moderator

Visitor Messages

Showing Visitor Messages 1 to 5 of 5
  1. snodge
    10th December 2017 10:21 AM
    snodge
    Hi John, I am having some problems with a KEL 84 that I am using and have just posted on the forum. I will be driving through Bracknell in early January. Could I drop the amp off if I haven't resolved the problem? Regards David
  2. John Caswell
    25th July 2016 11:14 PM
    John Caswell
    Hi David,
    Yes that is fine, give me a call beforehand as Thursday ams are out
    0118 973 2059: 07836 722413: john.caswell@johncaswell.co.uk
  3. snodge
    22nd July 2016 01:55 PM
    snodge
    Hi John,

    I am picking the 5881 amp up tomorrow and have ordered a new set of tubes from Watford Valves.

    I have opted for Svetlana 6L6 GC's GE JAN ECC83's and Siemens EF86's.

    Would it be OK to drop the amp off in the next couple of weeks?

    Kind regards

    David (snodge)
  4. New Boy
    3rd July 2013 05:56 PM
    New Boy
    Hi John
    Asking how to se you are placed on Friday ?


    Volume position change discussed a couple of weeks ago after the recent Pre 3 modification ?

    I may be able to make p.m. on Friday next ( July 3rd ) to achieve this - Is this a possibility for you ?

    Also I am experiencing a buzzing type oscillation through speakers - Cause may have been me as I have an upcoming tube rolling with kt88's wish to look at New Gold Lion quad from Hot-Rox currently unlistenable! Electro - Harmonix loud buzz ! also - "Used" recently purchased Svetlanas severe oscillation unthinkable to even try to use.

    The Gold Lions and Svets must turn off within
    seconds of switch on Svets severe - Dire. As you probably told me so !

    Curiously my touching the case (with my fingers) of the power supply or the pre 3s or the phono drops the oscillation to virtually non existent with EH. A switched off pre section seems to make no difference. I connected a lash up earth to the three cases and held a wire to the power amp casing with no effect. Any Ideas ?

    Regards

    Rod
  5. john jay
    30th September 2011 10:16 PM
    john jay
    hi john. thank you for your reply. silly me got the valve number wrong. should be a
    5691 double triode which i am told is a rugged version of the 6sl7gt valve would like to
    use this as a substitute for ecc83.any comment would be appreciated. regards to all
    john jay

About Me

  • About John Caswell
    Where are you? (you must fill this in)
    Wokingham, Berkshire
    Your Interest (you must fill this in)
    HiFi, DIY, photography
    Who you are in Hi Fi (you must fill this in)
    Radio & TV service engineer 'til 1973, then moved into Broadcast radio and Tv 'til 2005. Now service engineer for UKD and Audion plus repairing pretty well anything in the Hi Fi world

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 11th December 2017 11:47 PM
  • Join Date: 30th December 2005

All times are GMT +1. The time now is 05:48 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright World Designs