World-Designs-Forum

World-Designs-Forum (http://www.world-designs.co.uk/forum/index.php)
-   WD Other Parts and Projects (http://www.world-designs.co.uk/forum/forumdisplay.php?f=41)
-   -   Musical Fidelity A100 (http://www.world-designs.co.uk/forum/showthread.php?t=7088)

bob orbell 31st August 2014 09:46 AM

Musical Fidelity A100
 
Hi all, I am looking for some help with a MF A 100 int. amp. I have just been given, it is is very good cosmetic condition but does not work, these amp's are heavily biased in to class A operation and run HOT :eek: I need help with a CD and output transistor type, sadly, I am not at all good with transistors and have only a very basic understanding. I can see that two resistors have had a very hard time, and also some of the small electrolytic capacitors look swollen, I will replace all the cap's with 105c type and all the larger resistors. any help appreciated. BOB

Richard 31st August 2014 10:20 AM

Re: Musical Fidelity A100
 
Hi Bob,
This site gives some interesting info,
http://www.markhennessy.co.uk/mf_a1/

:D'oh!: edit sorry wrong amp but still an interesting read...

bob orbell 1st September 2014 11:57 AM

Re: Musical Fidelity A100
 
Thank's Richard, yes I have seen that, apparently the A100 & A1 are identical apart from the output transistors, and of course the power supply. I realy need a circuit diagram that is readable. BOB

Richard 1st September 2014 01:09 PM

Re: Musical Fidelity A100
 
email sent to you Bob.

bob orbell 1st September 2014 04:44 PM

Re: Musical Fidelity A100
 
Thank you, most help full, I will post if I get it going. BOB

bob orbell 5th September 2014 04:38 PM

Re: Musical Fidelity A100
 
A100 up and running again, the culprit was the bridge rectifier, gone short circuit but need to more tests on the four large smoothing capacitors, sounds very good, if a little soft in the base. BOB

Richard 5th September 2014 09:55 PM

Re: Musical Fidelity A100
 
Well done Bob :thumbsup: good to hear! I'm just giving a solid state amp that went off intermittently on one channel a good blast at the moment. I eventually tracked the problem to the speaker relay 4 from RS, very satisfying isn't it :)

colin.hepburn 5th September 2014 10:59 PM

Re: Musical Fidelity A100
 
Hi All
This must be the solid-state club repair thread then;)

I have just changed out the psu caps in the small-regulated pre amp psu in my NAD352C
As it had a nice hum one cap was blow out on the top so change all now working great again:thumbsup
:
I would hate this amp to really go wrong as it is full of safety relays ics which would be over my head to fix I would think :eek:

bob orbell 6th September 2014 09:36 AM

Re: Musical Fidelity A100
 
Hi all, I have been reading up on transistors, thinking that was the problem with the A100, really quite simple to test with just a multimeter, but as for those things with loads of legs, well, that is for the pros. I also have a Casio DAT DA7 recorder that I have looked at many times hoping to get it to work, but no joy, it;s all SMT and that is way beyond me :eek: BOB

bob orbell 10th September 2014 08:39 AM

Re: Musical Fidelity A100
 
Hi all you solid state traitor's :D I had this A100 running in the living room yesterday for over 4 hours, driving my PL100's, was quite expecting it to go pop, but it kept going, the whole thing gets so hot, it would burn skin.,but the sound is very smooth and almost dare I say, valve like, these amp's have quite a cult following, so I am going to keep it for some time and see if it's price goes up some, so far it's cost me 8.39, not bad. BOB


All times are GMT +1. The time now is 03:06 PM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright World Designs