World-Designs-Forum  

Go Back   World-Designs-Forum > World Designs > WD Amplifiers
Register FAQ Members List Calendar Gallery Today's Posts Mark Forums Read

WD Amplifiers For discusson of World Designs Amplifiers

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 14th November 2019, 10:02 PM
Bonky Bonky is offline
Member
 
Join Date: Feb 2018
Location: Sheffield
Posts: 92
Default KEL84 Conundrum/advice

The amp is just over a year old. It feeds Living Voice speakers (94dB efficiency). The preamp is a valve Schiit.

Over the last few weeks I think I've noticed a bass boominess. I plugged in a DADA-modified Quad 306 (after a few beers) and thought that it sounded better. I need to repeat the whole op tomorrow night (when my wife is away).

Assuming the same conclusions...what to do?
1. Sell the KEL84
2. Upgrade to the next WD amp (Kevin Scott the owner of LV reckons that valve amps sound better with his speakers).
3. Tube roll the KEL84 - if so - what are the recommendations?
4. Examine the KEL84 for component malfunction...(what...where....how?)

Thanks,
Richard.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 10:36 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright World Designs