World-Designs-Forum  

Go Back   World-Designs-Forum > World Designs > Problems
Register FAQ Members List Calendar Gallery Today's Posts Search Today's Posts Mark Forums Read

Problems For questions and answers re World Designs Projects

Reply
 
Thread Tools Display Modes
  #11  
Old 24th November 2011, 10:26 AM
HighFidelityGuy HighFidelityGuy is offline
Junior Member
 
Join Date: Mar 2011
Location: Sheffield, UK
Posts: 6
Default Re: KEL84 clicks and pops from right channel?

It's taken a while but I think I may have resolved this issue. It looks like it may have been an issue with one or more valves not fitting tightly enough in their socket. All the other things I tried didn't make any difference but after bending all the valve pins in a little so that they made a tighter fit I've so far not had any clicks or pops. So I'm really hoping that was the problem. Fingers crossed.

Many thanks for all your suggestions.
Reply With Quote
  #12  
Old 24th November 2011, 05:03 PM
John Caswell John Caswell is offline
Super Moderator
 
Join Date: Dec 2005
Location: Wokingham, Berkshire
Posts: 1,417
Default Re: KEL84 clicks and pops from right channel?

Hi all,
"but after bending all the valve pins in a little so that they made a tighter fit"
This is NOT a good idea as even a little bend is liable to fracture the glass "frit" seal as the valve is subject to heat cycles.
The most satisfactory and best solution is to change the base, I know it is a pain but it is cheaper than a new valve.

John
Reply With Quote
Reply

Tags
click, clicking, kel84, pop, problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 12:35 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright World Designs