World-Designs-Forum  

Go Back   World-Designs-Forum > World Designs > Problems
Register FAQ Members List Calendar Gallery Today's Posts Search Today's Posts Mark Forums Read

Problems For questions and answers re World Designs Projects

Reply
 
Thread Tools Display Modes
  #1  
Old 18th January 2020, 10:33 PM
A.N. Beal A.N. Beal is offline
Member
 
Join Date: Feb 2006
Location: Leeds, West Yorkshire, UK
Posts: 38
Default WD88XL switch off hiss

Dear Folks
My WD88XL works well, no problems when it is on. However when I switch it off there is a fairly loud hiss on the left channel, which then fades away over a few seconds. Swapping the valves between channels makes no difference - the hiss stays on the left channel. I therefore assume that it must be a dry joint somewhere in the left channel wiring. Can anyone suggest the most likely area that would cause this problem?
Regards,
Alasdair
Reply With Quote
  #2  
Old 19th January 2020, 01:23 AM
Richard Richard is offline
Super Moderator
 
Join Date: Dec 2005
Location: Notts
Posts: 4,770
Default Re: WD88XL switch off hiss

Hi Alasdair,
Firstly, could it be any pre-amp or source connected that is doing this? If any are connected turn them off first of course.
Then you could try to locate the area of the problem by removing the offending channel KT88s one at a time, fire up, wait, then power down and see if one affects the problem.
If no change, fire up with both KT88s installed and without the ECC83, see if that affects it. Then with all valves installed except the offending channel 5687. You get the idea I'm sure, the valves may be ok but one may be making a poor contact or it may indicate which part of the circuit has a fault.
Reply With Quote
  #3  
Old 21st January 2020, 06:38 PM
A.N. Beal A.N. Beal is offline
Member
 
Join Date: Feb 2006
Location: Leeds, West Yorkshire, UK
Posts: 38
Default Re: WD88XL switch off hiss

Dear Richard,
Thanks for the suggestions. I don't use a preamp (other than a phono preamp, which is permanently switched on) and the hiss only occurs when I switch the WD88 off, so I assume that is where the problem is. When I find time to work on it (probably in a fortnight or so) I'll try your suggestions to localise the fault and then poke around with my favoured tool (a plastic chopstick) to try to find the offending joint.
Regards,
Alasdair
Reply With Quote
  #4  
Old 22nd January 2020, 09:36 AM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 1,784
Default Re: WD88XL switch off hiss

Alasdair, does your WD88 have the relays for input selection ? if so, then the problem is with the 88 and not any external source, because as soon as power is switched off, the relay will close creating a dead short to the 88 input, if it does not have the relays it may be your phono. Bob
Reply With Quote
  #5  
Old 30th January 2020, 05:23 PM
A.N. Beal A.N. Beal is offline
Member
 
Join Date: Feb 2006
Location: Leeds, West Yorkshire, UK
Posts: 38
Default Re: WD88XL switch off hiss

Dear Bob,
My WD88 has relay selection of inputs and the noise occurs regardless of which input is selected, so I am sure the problem is in the WD88. I just need to work out where when I open it up.

Regards,
Alasdair
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 03:54 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright World Designs