World-Designs-Forum  

Go Back   World-Designs-Forum > World Designs > Problems
Register FAQ Members List Calendar Gallery Today's Posts Search Today's Posts Mark Forums Read

Problems For questions and answers re World Designs Projects

Reply
 
Thread Tools Display Modes
  #11  
Old 6th May 2016, 01:21 AM
Phil Y's Avatar
Phil Y Phil Y is offline
Senior Member
 
Join Date: Jul 2006
Location: Bristol, UK
Posts: 576
Default Re: KEL 84 Strange Noises

Hello Gavin,

Can you be a bit more specific about what noise you are getting ?
ECF80s can sometimes be a bit microphonic (they were not originally an audio valve) which can give quiet, high frequency ringing/pinging noises. Does this sound like what you are hearing ? If so, try gently tapping the offending valve a pencil or similar and see if this produces the same effect.

Phil
__________________
Commission for Dark Skies (CfDS)
Reply With Quote
  #12  
Old 6th May 2016, 10:56 AM
deepdown130 deepdown130 is offline
Junior Member
 
Join Date: Nov 2006
Location: Bristol
Posts: 16
Default Re: KEL 84 Strange Noises

Hi Phil

Yes - that is probably a better description of the sound. Although it certainly isn't quiet!

So I've put the valves back in that seem to reveal problem, waited for the sound then tapped. It was quite interesting because it seemed that the entire amp became "live" in that wherever I tapped, the tapping sound was amplified and transmitted through the left speaker. Then it would stop abruptly.

Putting the Edicrons back in solved the problem again.

If the sound changed sides when I swapped the valves over, it would make more sense to me but it stays on the left.

Weird!
Reply With Quote
  #13  
Old 6th May 2016, 02:34 PM
Phil Y's Avatar
Phil Y Phil Y is offline
Senior Member
 
Join Date: Jul 2006
Location: Bristol, UK
Posts: 576
Default Re: KEL 84 Strange Noises

Hello Gavin,
Sorry, I missed that it did not follow the valve. Probably a red herring then but it may give a clue to someone else.

Phil.
__________________
Commission for Dark Skies (CfDS)
Reply With Quote
  #14  
Old 7th May 2016, 10:56 AM
Richard Richard is offline
Super Moderator
 
Join Date: Dec 2005
Location: Notts
Posts: 4,500
Default Re: KEL 84 Strange Noises

Hi all,

So to re-cap, the Edicrons are ok but the Pinnacle and Mazdas cause the problem. The problem only happens in the left channel and does not follow the valves. The right channel is fine with all valves so far tested.

This suggests the valves and amp channels have slightly different electrical characteristics but it wouldn't usually be a problem unless the left channel is only marginally stable. It could be for reason of layout or components such as the winding of the output transformers. The design is usually stable but a combination of tolerances may affect the left channel.

The culprit might be input stage, output stage, or global feedback loop.

Does it still make the noise with the ECF80s removed?

Check the zobel connections are good across the outputs R36/37 C20/21.

Remove the left feedback wire from the positive red speaker post and clamp it firmly to the negative black speaker post. This disconnects the feedback loop and keeps the ECF80 cathode connection. If you play the amp you'll find it is very sensitive (loud) but should still work. See if the noise has stopped. It's easy to reduce global feedback if this is the problem.
__________________
'
Reply With Quote
  #15  
Old 7th May 2016, 08:53 PM
deepdown130 deepdown130 is offline
Junior Member
 
Join Date: Nov 2006
Location: Bristol
Posts: 16
Default Re: KEL 84 Strange Noises

Hi Richard

Yes - your summary is correct. I haven't tried the amp with the ECF80s removed. I'll try that and see what happens. You've lost me with zobel connections - what are they? Should I do these checks only if the noise is present with the ECF80s removed?

Many thanks for offering more help Richard.
Reply With Quote
  #16  
Old 7th May 2016, 09:14 PM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 1,450
Default Re: KEL 84 Strange Noises

The Zoblel network is the resistor and capacitor in series conected across the speaker terminals inside the amp. BOB
Reply With Quote
  #17  
Old 8th May 2016, 12:57 AM
deepdown130 deepdown130 is offline
Junior Member
 
Join Date: Nov 2006
Location: Bristol
Posts: 16
Default Re: KEL 84 Strange Noises

Quote:
Originally Posted by bob orbell View Post
The Zoblel network is the resistor and capacitor in series conected across the speaker terminals inside the amp. BOB
Thanks Bob.
Reply With Quote
  #18  
Old 8th May 2016, 11:32 AM
Greg.'s Avatar
Greg. Greg. is online now
Senior Member
 
Join Date: Dec 2005
Location: Bristol, UK
Posts: 2,992
Default Re: KEL 84 Strange Noises

Gavin, similar to an offer I have made to AndyC on another thread, I am also in Bristol (Frenchay) and I am familiar with KeL84 having built and owned one in the past and serviced a couple for other people. Also, I have been playing with WAD and WD kits for many years. You are very welcome to bring it over to me and see if we can find a solution to your problem. PM me if you would like to do this.
Reply With Quote
  #19  
Old 8th May 2016, 04:36 PM
deepdown130 deepdown130 is offline
Junior Member
 
Join Date: Nov 2006
Location: Bristol
Posts: 16
Default Re: KEL 84 Strange Noises

Greg

That's a very kind offer and I appreciate it. Unfortunately (for me), whilst I put Bristol as my location I actually live about 35 miles south of Bristol (if I put my actual village then nobody knows where it is so I always put Bristol as my location in forums).

I'm content (for now) to stick with the Edicrons while they still work fine.

Thanks again.

Gavin
Reply With Quote
  #20  
Old 8th May 2016, 04:48 PM
pre65's Avatar
pre65 pre65 is offline
Senior Member
 
Join Date: Jan 2006
Location: Ashen- Essex/Suffolk bord
Posts: 4,344
Default Re: KEL 84 Strange Noises

What is a 70 mile round trip to worry about when you can meet a new friend and get (possibly) a solution to your amp problem ?
__________________
Philip.

Everything in this post is my honest opinion based on what i thought I knew at that very moment in time.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 10:41 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright World Designs