World-Designs-Forum  

Go Back   World-Designs-Forum > World Designs > WD Other Parts and Projects
Register FAQ Members List Calendar Gallery Today's Posts Search Today's Posts Mark Forums Read

WD Other Parts and Projects All other WD Parts and Projects

Reply
 
Thread Tools Display Modes
  #1  
Old 7th July 2016, 08:45 PM
Cycleallday Cycleallday is offline
Member
 
Join Date: Jul 2006
Location: Andover, Hants
Posts: 77
Default WD Phono II help

After about 10 years of storage I have have decided to either use or sell my WD Pre/phono/power units.

First I would like to try out the phono against my current unit (the inbuilt phono in a Quad Classic Integrated) but first need to get it converted to handle moving coils as I had none when I last used these units.

Now my first problem is the folder with all my build details and instruction CD didn't survive the storage and the passage of time means I can remember virtual nothing of what I did although I know it was working fine.

Below are some photos which indicate the phono is moving magnet but I believe those 2 pots which are not connected are step up transformers - am I right or wrong and if not what are they?

If they are can somebody help me with the work to connect them up. If anybody can provide me with the CD build instruction files for all 3 units it would be most helpful.

Mel
Attached Images
File Type: jpg IMG_0454 (1).jpg (76.4 KB, 46 views)
File Type: jpg IMG_0457 (1).jpg (45.1 KB, 36 views)
Reply With Quote
  #2  
Old 8th July 2016, 09:09 AM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 1,450
Default Re: WD Phono II help

Hi Mel, just for correction, your Phono is a III, not a II, but it uses the WAD II board. It is simple to connect the SUT, the two cylindrical pots at the rear, but you can not have MM and MC together without the relay board and a switch to select one or the other, if you are happy to have just MC only input this is what to do. Remove the cable from the input phono plug to the input of the board, remove R13 - 14, 47k, and replace with 10k, connect the red and black cables from left SUT to left input on board, black to the ground connection red to the hot connection, repeat for right channel, now, do you know what MC cartridge you will be using, because the SUT has 1-10, and 1-20 options, for the 1-10 option, connect yellow and blue together and insulate, connect pink to the centre pin of the phono input left, and orange to the outer tag on the phono input, repeat for the right channel. For the 1-20, connect pink and yellow to the centre pin, and blue and orange to outer tag, I hope this helps you. BOB
Reply With Quote
  #3  
Old 8th July 2016, 03:03 PM
Cycleallday Cycleallday is offline
Member
 
Join Date: Jul 2006
Location: Andover, Hants
Posts: 77
Default Re: WD Phono II help

Thanks very much for those very clear instructions Bob and for pointing out it is a III unit and not a II - so I assume the remaining power and pre will also be III versions?

Does anybody have a copy of the build CD files for the WD III phono/pre/power units or point me to where I may find them?

Many thanks,

Mel
Reply With Quote
  #4  
Old 8th July 2016, 04:16 PM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 1,450
Default Re: WD Phono II help

Hi Mel, you may now have to ask Matthew for the build instructions, there has been a post recently about members and moderators exchanging details, and it may infringe Matthews copy right, give him a shout to confirm, if you had the kits off him he may well oblige with a replacment. BOB
Reply With Quote
  #5  
Old 9th July 2016, 01:09 PM
Cycleallday Cycleallday is offline
Member
 
Join Date: Jul 2006
Location: Andover, Hants
Posts: 77
Default Re: WD Phono II help

Thanks for the update Bob, after a hour or so trawling through my computer files I have finally found the WD Series 3 CD contents so thats one problem solved :-)

Mel
Reply With Quote
  #6  
Old 9th July 2016, 03:29 PM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 1,450
Default Re: WD Phono II help

Thats good Mel, if you have problems, just ask. BOB
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 10:41 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright World Designs