World-Designs-Forum

World-Designs-Forum (http://www.world-designs.co.uk/forum/index.php)
-   Problems (http://www.world-designs.co.uk/forum/forumdisplay.php?f=5)
-   -   New build WDPhono 3 Questions; heater voltage/LED (http://www.world-designs.co.uk/forum/showthread.php?t=7729)

G Willis 14th February 2019 08:13 PM

Re: New build WDPhono 3 Questions; heater voltage/LED
 
I've ordered a new regulator and some power resistors from Matthew. I need to redo some of this. I will let you know how I get on....

Thanks, Graham

G Willis 17th February 2019 06:54 PM

Re: New build WDPhono 3 Questions; heater voltage/LED
 
I have now done the following:

1. Replaced all the power resistors so that they are well clear of the board
2. Replaced the regulator and fitted as described by Bob. This was much easier second time around as I fitted it to the chassis but only soldered it to the board when all the other wiring was complete.
3. I rewired all the pins in the PSU ensuring good joints. I now have a good technique for doing this.
4. Redid some of the soldering in the Phono3

The good news is that now the heater is at 6.5v as stated.

Thank you all for your help. I can now set up my record deck. :D:D:D

Graham

bob orbell 18th February 2019 07:34 AM

Re: New build WDPhono 3 Questions; heater voltage/LED
 
Well done Graham, let us know your thoughts on it, although I am going to say that you may find it a bit bright, if it is I do have a fix :thumbsup:. Bob

G Willis 22nd February 2019 01:44 PM

Re: New build WDPhono 3 Questions; heater voltage/LED
 
Just an update on this: I have set up my deck and it all sounds absolutely fabulous. Very happy. :D:thumbsup:


All times are GMT +1. The time now is 07:43 PM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright World Designs