View Single Post
  #8  
Old 11th February 2019, 09:43 PM
bikerhifinut bikerhifinut is offline
Senior Member
 
Join Date: Jan 2006
Location: Penrith, Cumbria
Posts: 1,071
Default Re: New build WDPhono 3 Questions; heater voltage/LED

is it a Phono 3S? if so theres bits you haven't fitted. Like the rest of the interstage coupling capacitors that form the LF filter before the first RIAA correction network.
Those heater connections don't look right to me, I didnt build mine so I've never looked underneath it. However what you could do is solder the heater wiring DIRECTLY to the relevant solder pin pads i.e. pin9 fpr - and pins 4/5 for + to save confusion.
Or take valves out of sockets and with the unit unplugged from power, use a meter on resistance range and check the continuity from the actual valve base pins to all the heater solder points, all should measure zero ohms between their relevant pins and back to the powersocket. That is all pin 9 should measure zero ohms between each other and back to the plug and likewise all pin 4/5 zero and back to the plug. With the LED disconnected the meter should show no circuit between pins 9 and pins 4/5 as the valve heater filament completes the circuit.
I think theres something not right with your heater wiring.
Theres a few others have actually built this circuit who can shed more light on it. My eyes were spinning trying to follow the board tracks. at these times I would have been metering to see where the solder pads were connected.

Andy.
Reply With Quote