World-Designs-Forum  

Go Back   World-Designs-Forum > World Designs > WD Amplifiers
Register FAQ Members List Calendar Gallery Today's Posts Mark Forums Read

WD Amplifiers For discusson of World Designs Amplifiers

Reply
 
Thread Tools Display Modes
  #11  
Old 21st July 2014, 09:05 AM
John Caswell John Caswell is offline
Super Moderator
 
Join Date: Dec 2005
Location: Wokingham, Berkshire
Posts: 1,640
Default Re: Diode's on pre III relay board

Hi Bob et al,
I suspect "catastrophic failure" here. Silicon devices are pretty bomb proof but there is always the odd one!

John
Reply With Quote
  #12  
Old 21st July 2014, 11:07 AM
bikerhifinut bikerhifinut is offline
Senior Member
 
Join Date: Jan 2006
Location: Penrith, Cumbria
Posts: 1,060
Default Re: Diode's on pre III relay board

Unlucky maybe Bob?
Perhaps a bad batch got past QC?

Andy.
Reply With Quote
  #13  
Old 15th April 2021, 10:32 AM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 2,186
Default Re: Diode's on pre III relay board

Just an update on this subject, is it seven years , I did replace the diodes with 1000 volt jobs as Richard and John suggested and a new board from Matthew, all is fine to date and I even changed the diodes in the Phono . Bob
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 09:13 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright World Designs