World-Designs-Forum  

Go Back   World-Designs-Forum > World Designs > Problems
Register FAQ Members List Calendar Gallery Today's Posts Mark Forums Read

Problems For questions and answers re World Designs Projects

Reply
 
Thread Tools Display Modes
  #1  
Old 29th November 2019, 05:20 AM
YummyFuzz YummyFuzz is offline
Junior Member
 
Join Date: Sep 2019
Location: Perth, Australia
Posts: 10
Default KEL84 noise in left channel

Hello WD forum,

I want to see if anyone had some suggestions on some noise coming from my KEL84 amp if I describe the symptoms.

Setup: KEL84 powered-on with speakers connected, but no audio inputs.

- A moderate volume intermittent popping/rustling comes from the left channel only for about 10 minutes after powering on from cold.
- If left on, the sound does not seem to reoccur when the amp is warm/hot.
- The sound stays at the same level, regardless of the position of the volume knob, or the input/mute selection.
- The sound remains in the left channel even when I swap the tubes one-by-one between left and right (i.e. It doesn't follow a tube).
- It's not the speakers (if I swap the speaker wires L2R and R2L it comes out the right speaker).

If there is an input audio signal playing (at low volume) during this time, the popping rustling can be heard just under the audio. The audio does not cut out or reduced in volume when this noise happens.

So I'm guessing it is one of the electrolytic capacitors on the left channel of the amp, which I can try replacing.
Does this seem right, or are there other tests or components I should try?

(This is the KEL84 that I found at the recycling centre so I'm not sure where or how it may have been stored in the past.)
Reply With Quote
  #2  
Old 29th November 2019, 06:55 AM
Ali Tait's Avatar
Ali Tait Ali Tait is offline
Senior Member
 
Join Date: Dec 2005
Location: Leeds
Posts: 937
Default Re: KEL84 noise in left channel

First thing to try is swapping valves between channels and see if the noise follows any of them.
Reply With Quote
  #3  
Old 29th November 2019, 07:27 AM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 2,255
Default Re: KEL84 noise in left channel

His post says that he has done that . Bob
Reply With Quote
  #4  
Old 29th November 2019, 09:00 AM
John Caswell John Caswell is offline
Super Moderator
 
Join Date: Dec 2005
Location: Wokingham, Berkshire
Posts: 1,649
Default Re: KEL84 noise in left channel

Hi,
I would doubt it being a noisy capacitor more likely a noisy resistor or possibly a dirty PCB.
I would guess that from your description the nose is there all the time , so remove all inputs, volume at minimum and check if the noise is still there.
If so then suspect noisy anode/screen/cathode resistors on/around the ECF80.
Substitution is the only known check I'm afraid.

John
Reply With Quote
  #5  
Old 29th November 2019, 09:14 AM
snowman_al snowman_al is offline
Member
 
Join Date: Nov 2016
Location: West Wales
Posts: 77
Default Re: KEL84 noise in left channel

If you pull the ECF80 out, do you still get the popping noise?
If yes look at the components round the EL84, if no look at the components round the ECF80.
Sounds like a heat related issue, could be a simple poor connection in a valve holder or dry joint on the board or wiring. Give the valves a jiggle - does that make it better or worse?
Equally likely to be a noisy resistor. If removing the ECF80 clears the problem, then suspect the 100k resistor R10/11 first, then the 2 x 27k resistors R12/13/14/15.

Not sure it will tell you anything, but check the voltage measurements round the 'noisy' side and compare to the good side.

Crossed posts...

Last edited by snowman_al; 29th November 2019 at 09:17 AM. Reason: Crossed posts
Reply With Quote
  #6  
Old 29th November 2019, 09:40 AM
Ali Tait's Avatar
Ali Tait Ali Tait is offline
Senior Member
 
Join Date: Dec 2005
Location: Leeds
Posts: 937
Default Re: KEL84 noise in left channel

Quote:
Originally Posted by bob orbell View Post
His post says that he has done that . Bob
Ah cmon, it was early!
Reply With Quote
  #7  
Old 29th November 2019, 12:56 PM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 2,255
Default Re: KEL84 noise in left channel

Quote:
Originally Posted by Ali Tait View Post
Ah cmon, it was early!
Sorry Ali, I forgot, you are about 1.5 hours behind us down here . Bob
Reply With Quote
  #8  
Old 29th November 2019, 02:40 PM
Ali Tait's Avatar
Ali Tait Ali Tait is offline
Senior Member
 
Join Date: Dec 2005
Location: Leeds
Posts: 937
Default Re: KEL84 noise in left channel

Oi, I'm in Leeds now oi'll have yer know.
Reply With Quote
  #9  
Old 29th November 2019, 08:00 PM
Greg.'s Avatar
Greg. Greg. is offline
WD Archivist
 
Join Date: Dec 2005
Location: Bristol, UK
Posts: 3,467
Default Re: KEL84 noise in left channel

Quote:
Originally Posted by Ali Tait View Post
Oi, I'm in Leeds now oi'll have yer know.
Youíll need a visa soon if a certain red topped fish woman gets her way
Reply With Quote
  #10  
Old 30th November 2019, 08:00 PM
Ali Tait's Avatar
Ali Tait Ali Tait is offline
Senior Member
 
Join Date: Dec 2005
Location: Leeds
Posts: 937
Default Re: KEL84 noise in left channel

LOL Iím dual nationality.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 03:42 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright World Designs