World-Designs-Forum  

Go Back   World-Designs-Forum > World Designs > Problems
Register FAQ Members List Calendar Gallery Today's Posts Mark Forums Read

Problems For questions and answers re World Designs Projects

Reply
 
Thread Tools Display Modes
  #1  
Old 27th February 2018, 11:26 PM
bikerhifinut bikerhifinut is offline
Senior Member
 
Join Date: Jan 2006
Location: Penrith, Cumbria
Posts: 1,089
Default Phono3S it's humming again.

The Phono3S has a rather nasty 50hz hum on the MM input.
As far as I can ascertain, there's no hum with the inputs shorted out on the Mute setting and even open circuit on the MC setting there isnt a hum issue. I tried the arm leads plugged in to the MC input and again no hum issue even with a MM cartridge in the arm.
The issue seems to be as soon as the arm leads are plugged into the MM input an awful hum ensues.
My suspicions are that there is something amiss with the relay board, perhaps a faulty earth return on the Mm sockets or a dodgy relay?
I am sure it isnt a positioning issue, there has never been a problem previously with the layout and the big mains transformer on the power amp (WD 88VA) is well away from the sensitive phono stage.
Likewise the arm earthing is fine. I also tried a separate earth lead from the arm base to the earth post as it's a Rega arm with the earth incorporated in the LH arm lead. Just to make sure I swapped in an arm with a separate earth wire and the issue is still there.
So where do i start with the fault finding?
I was tempted to wire up a pair of Floating phono sockets directly to the input pins on the PCB on the assumption if that eliminated the hum then the problem does lie with the relay board.

Andy.
Reply With Quote
  #2  
Old 28th February 2018, 08:22 AM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 2,369
Default Re: Phono3S it's humming again.

Hi Andy, to be honest, I think that the relay board is all wrong, but only with regard to MC, I had a hum issue with mine but sorted it by rewiring and not allowing chassis earth, or arm earth to connect to any of the incoming cartridge pins, ie, floating, the SUT's also with no connection to earth, or o volts, primary winding only, and now I can lift the volume to full, with MC, arm in the rest and just a gentle hiss. I have put the pictures on but they don't show much. BOB
Attached Images
File Type: jpg HPIM0493.JPG (122.4 KB, 22 views)
File Type: jpg HPIM0494.JPG (96.8 KB, 19 views)
Reply With Quote
  #3  
Old 28th February 2018, 09:34 AM
Richard Richard is offline
Super Moderator
 
Join Date: Dec 2005
Location: Notts
Posts: 5,185
Default Re: Phono3S it's humming again.

It might be worth re-checking the earthing arrangement.

As standard Phono case "earth" post is actually signal ground and is connected to mains earth in PSU via 100R.

PSU case earth post is connected to mains earth directly.

So there are 2 possible earth points for the TT; signal ground on Phono and mains earth on PSU.

You should be able to find this 100R with a meter and try the TT earth connection on both to see which is better. If your TT is to mains earth it might be worth trying it to signal ground (may isolate it from a ground loop) and vice versa.
Reply With Quote
  #4  
Old 28th February 2018, 12:40 PM
bikerhifinut bikerhifinut is offline
Senior Member
 
Join Date: Jan 2006
Location: Penrith, Cumbria
Posts: 1,089
Default Re: Phono3S it's humming again.

OK.
You may remember when I first got this phono3 used, I had a real issue with hum that turned out to be the PSU earth lift resistor not being in circuit, in fact the whole PSU was a crock of that smelly stuff. To that end the PSU is now a fully regulated job and that solved everything.
So reconnecting arm earth to mains earth isn't going to be a solution I feel. And in any case its a Rega RB600 arm so there isn't a separate earth wire, it's earthed via the LH arm lead screen. The same issue occurs with the spare OL1 arm which does have a separate earth wire.
I have been getting the odd crackle which I put down to a valve going noisy but now I am wondering if it's a dry joint somewhere, most likely on the relay board which looks very complicated.
Like Bob I do wonder why the relay board is necessary? For me a simple toggle switch with gold plated contacts on the rear panel to select MC or MM would have been simpler and just as effective.
Anyway, if it is the board at fault it doesnt look very easy to fault find or rectify and I suspect the cure is a replacement board.
I hope not. But replacing the input relay board with a pair of floating phono sockets for testing will identify if the fault lies in the relay board. The unit doesnt hum open circuit or muted so it isn't intrinsically hummy obviously.
But when I get it fixed I strongly suspect I will be selling it on. I have another case I can put my regulated PSU in and a new PSU3 PCB and a couple of spare mains transformers so I can restore the PSU3 to original.

Andy
Reply With Quote
  #5  
Old 28th February 2018, 12:43 PM
bikerhifinut bikerhifinut is offline
Senior Member
 
Join Date: Jan 2006
Location: Penrith, Cumbria
Posts: 1,089
Default Re: Phono3S it's humming again.

Just for the record, the turntable is a Michell Gyro SE which has a DC motor and is isolated from the mains so the only earth connection is via the tonearm.
A.
Reply With Quote
  #6  
Old 28th February 2018, 02:06 PM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 2,369
Default Re: Phono3S it's humming again.

I would't give up yet Andy, as said, mine is excellent, I do agree that the relay board is very fiddly but dose work well if assembled with care and floating inputs, that, I am sure you can figure out. BOB
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 01:07 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright World Designs