World-Designs-Forum  

Go Back   World-Designs-Forum > World Designs > WD Other Parts and Projects
Register FAQ Members List Calendar Gallery Today's Posts Mark Forums Read

WD Other Parts and Projects All other WD Parts and Projects

Reply
 
Thread Tools Display Modes
  #41  
Old 23rd August 2020, 04:27 PM
colin.hepburn colin.hepburn is offline
Super Moderator
 
Join Date: Jan 2006
Location: Newtonhill Aberdeenshire
Posts: 2,643
Default Re: WAD Psu3 replacement Board Build

I know my fault finding skills are not very good but what am I missing hear
Still not working I took the led out of circuit to stop it confusing me. And the Relay Board still tests 6.3v neg on the positive pin? And 45v on the positive pin to ground.

I even swopped the wire to the Relay Board around and still get 6.3v neg on the positive pin and yes I have the probes correct way round
Now fed up with this thing. I have now given up on it
Colin
__________________
The Blues man

Turntable Rega 3 custom RB250 with ortofon 2M Blue /other goldring 1042 /WD phono2 /WD CF pre custom converted /WD psu2 /home built JE Labs Single Ended 6SL7/KT66/Speakers Frugal horns Mk1s
Other turntables AR EB101/Thorns TD150mk2/Thorns TD160mk2


If you have trouble reading my posts its because I am a dyslexic member
Reply With Quote
  #42  
Old 24th August 2020, 07:30 AM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 2,363
Default Re: WAD Psu3 replacement Board Build

Colin, don't give in, if you wish I will correct it for you, but you will have to pay postage each way, no other charge, I do like fault finding. PM me if interested. Bob
Reply With Quote
  #43  
Old 24th August 2020, 10:08 AM
Richard Richard is offline
Super Moderator
 
Join Date: Dec 2005
Location: Notts
Posts: 5,184
Default Re: WAD Psu3 replacement Board Build

Quote:
Originally Posted by colin.hepburn View Post
I know my fault finding skills are not very good but what am I missing hear
Still not working I took the led out of circuit to stop it confusing me. And the Relay Board still tests 6.3v neg on the positive pin? And 45v on the positive pin to ground.

I even swopped the wire to the Relay Board around and still get 6.3v neg on the positive pin and yes I have the probes correct way round
Now fed up with this thing. I have now given up on it
Colin

Hi Col,
It's been a while since I built mine but looking at the PSU3/Pre3 circuits I wonder if you have a connection to Mains Earth rather than Signal Ground somewhere.
The PSU chassis is Mains Earth. The Pre3 case was Signal Ground. The heaters should show 6.7V difference between +/- and measure 46.7V and 40V to Mains Earth.
The relay power input +/- should show the same readings as the valve heater voltages, and both are floating from the PSU Mains Earth chassis.
I'd check for these earth paths with the continuity meter and power off but don't know if any damage may have been done if the relays/resistors/diodes have been run at too high voltage. If you find an earthing fault and correct it test voltages again with power on and re-do the relay board and LED if needed.
Hopefully something like this and sorry to be a distraction if yours isn't set up as the original build
Reply With Quote
  #44  
Old 24th August 2020, 02:03 PM
colin.hepburn colin.hepburn is offline
Super Moderator
 
Join Date: Jan 2006
Location: Newtonhill Aberdeenshire
Posts: 2,643
Default Re: WAD Psu3 replacement Board Build

Hi Richard /Bob/All
Thanks for the offer to look at it for me Bob. I will keep at it for now and see if I can improve my fault finding skills? And follow up on what Richard said in his post. I just got a bit frustrated with it yesterday.

Just to back up a bit I agree that leaving the CF pre switched on should have been ok. But it was left on due to the front panel led not being lit up. So I was not aware it was still switched on. And I didnít think to check it.

Note this was with the old PSU2 so what happened. Well I suspected it may have been a mains surge or was the old psu2 as some of the PCB track was a bit on the dodgy. Thatís why I scraped it or was it the Rely board.

Anyway fast forward with the PSU 3 the wiring colours used was as per the manual. I also made up new umbilicalís following the same colours all the way though which are hard wired to the PSU and to the plugs as normally at the Pre and phono ends just to say that the phono is working just fine on the PSU3.
Richard
Thanks for your reply and help. I will follow up on what you said later to night and post updates on voltages things as I go and I hope you all can read a fig out what I am typing ok with my **** spelling thanks again for your patients it is appreciated

Ha the dyslexic fault finder thatís a good one what will come of this I wonder
Thanks
Colin
__________________
The Blues man

Turntable Rega 3 custom RB250 with ortofon 2M Blue /other goldring 1042 /WD phono2 /WD CF pre custom converted /WD psu2 /home built JE Labs Single Ended 6SL7/KT66/Speakers Frugal horns Mk1s
Other turntables AR EB101/Thorns TD150mk2/Thorns TD160mk2


If you have trouble reading my posts its because I am a dyslexic member
Reply With Quote
  #45  
Old 24th August 2020, 06:23 PM
colin.hepburn colin.hepburn is offline
Super Moderator
 
Join Date: Jan 2006
Location: Newtonhill Aberdeenshire
Posts: 2,643
Default Re: WAD Psu3 replacement Board Build

HI All
Right I have just been having another look at this following Richards post so I have mains earth back to earth tag on the back panel and from there on to the PCB GND pin continuity check from PSU 3 chassis to Pre chassis give me a reading of a 100ohms

There is another GND pin on the other side of the PCB next to the bridge rectifier diodes not connected to anything so I clip leaded it to the earth tag on the back panel this gives me a continuous continuity beep between both PSU/PRE chassis so am I on the right track? now

Colin
__________________
The Blues man

Turntable Rega 3 custom RB250 with ortofon 2M Blue /other goldring 1042 /WD phono2 /WD CF pre custom converted /WD psu2 /home built JE Labs Single Ended 6SL7/KT66/Speakers Frugal horns Mk1s
Other turntables AR EB101/Thorns TD150mk2/Thorns TD160mk2


If you have trouble reading my posts its because I am a dyslexic member
Reply With Quote
  #46  
Old 24th August 2020, 10:47 PM
Richard Richard is offline
Super Moderator
 
Join Date: Dec 2005
Location: Notts
Posts: 5,184
Default Re: WAD Psu3 replacement Board Build

Hi Col, this is difficult to explain at a distance.
You have PSU and PreCF or Pre3 with relay input I think.
They're hard wired without sockets. Are they 5core wired or 4 core wired?
PSU has it's case at Mains Earth as standard. Have you wired you PreCF/3 to have a Mains Earth case (5 wire umbilical) or a Signal Ground case (4 wire umbilical)?
Reply With Quote
  #47  
Old 24th August 2020, 11:19 PM
colin.hepburn colin.hepburn is offline
Super Moderator
 
Join Date: Jan 2006
Location: Newtonhill Aberdeenshire
Posts: 2,643
Default Re: WAD Psu3 replacement Board Build

HI Richard

I have PSU3 and the older pre 2 converted to the Pre CF. with relay board by Bob. Which I got from him year ago the PSU is mains earthed the umbilicalís are hard wired only at the PSU end and the normal 4 pin plugs at the pre and phono end and are Signal Ground case (4 wire
__________________
The Blues man

Turntable Rega 3 custom RB250 with ortofon 2M Blue /other goldring 1042 /WD phono2 /WD CF pre custom converted /WD psu2 /home built JE Labs Single Ended 6SL7/KT66/Speakers Frugal horns Mk1s
Other turntables AR EB101/Thorns TD150mk2/Thorns TD160mk2


If you have trouble reading my posts its because I am a dyslexic member
Reply With Quote
  #48  
Old 25th August 2020, 10:09 AM
Richard Richard is offline
Super Moderator
 
Join Date: Dec 2005
Location: Notts
Posts: 5,184
Default Re: WAD Psu3 replacement Board Build

Hi Col,
OK so that's as original WD instructions. You should be able to check for 100R between ALL signal ground points and the case earth post of PSU.
So clip one probe to case post of PSU and use the other to probe,
the outer shells of the RCA sockets,
the GRD solder pins on the relay pcb,
the GRD solder pins on the CF pcb,
etc
If any have no 100R lift they are short to Mains Earth somewhere.
I didn't realise you'd got it from Bob and think letting him have a look at it if you can't find anything would be a very good idea as he is very familiar with this kit and his builds
Reply With Quote
  #49  
Old 25th August 2020, 10:32 AM
bob orbell bob orbell is offline
Senior Member
 
Join Date: Nov 2009
Location: kettering northants.
Posts: 2,363
Default Re: WAD Psu3 replacement Board Build

Hi Richard/Colin, Richard, the test you have given Colin will apply to my build but I ask, how could Colin assemble the PSU PCB incorrectly, the only thing I can think of, is, is the regulator (LD1084) insulated completely from the chassis ? and has Colin connected correct pin out, the problem must be something very simple, but a lot of folk are looking for a more dramatic problem, offer still stands though. Bob
Reply With Quote
  #50  
Old 27th August 2020, 05:27 PM
colin.hepburn colin.hepburn is offline
Super Moderator
 
Join Date: Jan 2006
Location: Newtonhill Aberdeenshire
Posts: 2,643
Default Re: WAD Psu3 replacement Board Build

Hi Richard /Bob/All
Ha well Success its up and running again
So what did I do wrong well as Bob pointed at earlier the umbilical wires were reverse Due to me hardwiring then to the PSU PCB.

I was looking at the plug from the wrong side i.e. the plug end as opposed to the solider pin side .not helped by the manuals mirror image illustration of the plugs. Mirror imaging and Dyslexia donít mix well so I will redraw the umbilical in my manual so same mistake canít happen next time do this type of wiring

I also had to strip the relay board down to replace a couple of the diodesí and re solder a ground wire which may have came off when stripping the board down stripping it down was easier to do than expected just required a larger soldering tip some braid and lots of flux.

My thanks to Richard and Bob For their guidance
This has been copied and pasted from your posts into the manual for my reference
Just shows you the support and value of this WD forum and its members can have for you
Thanks All
Colin
__________________
The Blues man

Turntable Rega 3 custom RB250 with ortofon 2M Blue /other goldring 1042 /WD phono2 /WD CF pre custom converted /WD psu2 /home built JE Labs Single Ended 6SL7/KT66/Speakers Frugal horns Mk1s
Other turntables AR EB101/Thorns TD150mk2/Thorns TD160mk2


If you have trouble reading my posts its because I am a dyslexic member
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 11:51 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright World Designs